Spracheinstellung auf Englisch

Hallo,

ich würde gerne Combit dazu bringen, bei bestimmten Benutzern stets die englische Oberfläche zu verwenden. Da die User automatisch angemeldet werden sollen, kommt eigentlich nicht die Anmeldemaske. Windows-Oberfläche ist Englisch. Gibt es dazu ein bewährtes Vorgehen?

Jetzt gerade habe ich noch ein besonderes Problem: Bei einem Benutzer kommt nach dem Start immer diese Fehlermeldung:

14-03-2022_08-11-41

Registry-Schlüssel „Language“ und „LanguageManager.LangID“ habe ich schon gelöscht. Windows-Oberfläche ist Englisch. Ohne automatische Anmeldung kann ich beim Login ja Deutsch auswählen, dann kommt die Meldung nicht.

Aber wenn der Benutzer in Konto-Allgemeines auf „Englisch“ wechselt oder/und beim Login „Englisch“ auswählt, kommt die Meldung. Wie bekomme ich das bereinigt? Der Benutzer möchte nur Englisch benutzen. Irgendwo muss eine abweichende Sprache für diesen Benutzer hinterlegt sein, nur wo?

Viele Grüße
Oliver

combit CRM merkt sich die eingestellte Sprache unter
Computer\HKEY_CURRENT_USER\SOFTWARE\combit\Appearance im REG_DWORD Schlüssel LanguageManager.LangID - Für Englisch muss darin eine 9 stehen. Für Deutsch eine 7. Jeder andere Wert führt zu einem Fehler, da die Sprache nicht gefunden werden wird (siehe .lng Ordner unten).

Darüber hat der:die Anwender:in also im funktionierenden Fall das nächste Mal wieder automatisch seine:ihre zuletzt eingestellte Sprache (nämlich über seine:ihre Windows-Registry).

Sie könnten das per Gruppenrichtlinie für die entsprechenden Anwender:innen verteilen, oder aber diese stellen eben 1 Mal unter ‚Konto > Allgemein > Oberfläche‘ für sich die Sprache um.

Zusätzlich muss darauf geachtet werden, dass im Client-Installationsverzeichnis wirklich auch der entsprechende Englische Sprach-Unterordner vorhanden und nicht leer ist (darum kümmert sich das Client-Setup und der Update-Dienst natürlich automatisch, aber bei einem pot. Problem muss man ja mal wo anfangen zu suchen :slight_smile: )


(für 7=DE gibt es keinen Ordner, das hat dann seine Richtigkeit)

Wenn diese Information zur Problemlösung nicht reicht - weil Sie schreiben, Sie hätten schon in der Registry die beiden Keys (wirklich die an dieser Stelle?) ohne Besserung gelöscht - müssen wir uns das über den combit Support ansehen. Setzen Sie meinen o.a. Schlüsselwert statt Löschen einmal explizit auf 7 bzw. 9 - geht es dann?

Selbst nach Profillöschung bekomme ich diesen Benutzer nur insoweit auf Englisch, als dass Combit komplett mit englischer Oberfläche startet und arbeitet. Jedoch beim Start bekommt er die gezeigte Meldung. Da muss doch etwas in der Datenbank stecken?

:point_up: bitte kurz ausprobieren - sonst bitte Support Case anlegen

Den Ordner 0009.lng gibt es, und der Registry-Key ist gesetzt. Support-Ticket habe ich eröffnet.

Die Ursache der Meldung ist ein Script, welches im Ereignis „Projekt wurde geöffnet“ ausgeführt wurde, um möglicherweise zu verhindern, dass die Sprache der Oberfläche unterschiedlich zur Sprache der Solution ist.

1 „Gefällt mir“

© combit GmbH