+49 (0)7531 906010| service@combit.net

Scriptfehler ui.js nur bei Win10 Version 1809 CRM 9 (9.007)

Guten Morgen,
bei den Clients, welche das aktuelle Windows 10 1809 nutzen, kommt es in der Info-Zentrale zu einem Script-Fehler. Combit ist auf dem aktuellen Stand b[/b], die Clients wurden ebenfalls auf den neusten Stand gebracht. Clients mit der Windows-Version 1803 haben dieses Problem nicht.
Kennst jemand dieses Problem?

Peter Vossen

2019-05-23-06_13_07-Skriptfehler.png

Hallo!
Ich kenne diesen Eintrag in der Knowledgebase:

https://support.combit.net/crm-software/service/crm-knowledgebase/knowledgebase/allgemeine-hinweise/info-zentrale-unter-windows-81/

da geht es auch um LoadBackgroundImageVBS

Hoffe das hilft!

Hatte ich auch gefunden, allerdings sind diese Änderungen seit geraumer Zeit als Standard implementiert.

Trotzdem Danke

Hi Peter,

es sieht für mich so aus, als könne bei dir der Internet Explorer (die Info-Zentrale läuft in einem Internet Explorer) das VBS nicht (mehr) vom Javascript aus aufrufen.

Vielleicht ist da irgendein Security Update dran schuld…

Ist die 192.123.114.200 (der Ort, wo deine Info-Zentrale-Dateien liegen) immer noch in der vertrauenswürdigen Zone? Evtl. ist die dort rausgeflogen?

Evtl. mal das hier angucken https://support.microsoft.com/de-de/help/4012494/option-to-disable-vbscript-execution-in-internet-explorer-for-internet und für die vertrauenswürdige Zone prüfen, ob das noch aktiviert ist?

Gruß

Alex

Hallo Alex,
da hatte ich auch schon dran gedacht, allerdings ändert sich in der Regel, beim Update von der 1803 auf die 1809, nichts an diesen Einstellungen. Über die Logik hatte ich dies ausgeschlossen, werde es mir aber mal anschauen.

Gruß
Peter

Hi Alex,
hätte ich nicht gedacht, aber das war das Problem. Die standardmäßigen Sicherheitseinstellungen scheinen sich derart bei der 1809 verschärft zu haben, dass man explizit Adressen aus der als sicher geltenden Domäne freigeben muss.
Danke dir

Gruß
Peter

Hallo,

mein Kollege Herr Grawert hat die Ursache gefunden und einen Workaround erstellt. Bei uns ist das Problem nun gelöst.

Editor für lokale Gruppenrichtlinien aufrufen:
„cmd.exe“ (als Administrator ausführen)
„gpedit.msc“ starten
Zu dieser Stelle navigieren:
Computerkonfiguration -> Administrative Vorlagen -> Windows-Komponenten
-> Internet Explorer -> Internetsystemsteuerung -> Sicherheitsseite
-> Internetzone
Folgende Gruppenrichtlinie anpassen:
VBScript-Ausführung in Internet Explorer zulassen

  • Richtlinie aktivieren
  • Optionen auf Aktivieren stellen

Viel Erfolg.

© combit GmbH