+49 (0)7531 906010| service@combit.net

Scripteditor startet nicht

Hallo an alle,

da ich vermehrt Scripte anpassen muss, wäre es sehr hilfreich wen der unter Tool , oder ein selber einstellbarer Editor beim Klick auf „Script bearbeten“ sich öffen würde.

Leider bekomme ich aber immer nur eine Fehlemeldung, die mi …\edit endet.

Wir arbeiten im Netz und der Ordner …\Tools\Editor ist vorhanden.
Auch die Dateiendung *.vbs ist mit dem Editor als Standartapplikation verbunden.

Wie kann ich es einstellen dass am besten Notebad++ aus dem eingabemaskeneditor startet?

Danke

Hallo!
Wurde das Client-Setup denn auf dem PC ausgeführt?
Dieses richtet eigentlich genau diese Einstellungen auf dem jeweiligen Client ein.

Mfg

Hallo und Danke für die Antwort.

Ja, das Client-Setup wurde benutzt.!

Gibt es irgendeinen eintrag in einer .ini Datei vieleicht?

mfg

Hallo

Um den Editor auf SciTE/Notepad++ umzustellen einfach folgendes tun

Rechtsklick auf die .vbs Datei
-> öffnen mit
-> Standardprogramm auswählen…

Programm aus der Liste auswählen (da sieht man die installierten Programme)

oder auf

-> Durchsuchen

und z.b. zu Notepad++ navigieren
(SciTE findest du im crm\Tools\Editor Verzeichnis)

Wenn man sich dann sicher ist den Haken bei
-> Dateityp immer mit dem gewählten Programm öffnen
setzen

Dann sollte der gewünschte Editor eingestellt sein

MfG

Hallo MM,

Danke für den Hinweis.
ABER: Ich bin der Technik des Windows mächtig ;-}
Solche Standards kenne ich.

Es geht darum, dass CRM6 irgendwo einen fest verdrahteten Link zum Editieren eines VBS-Scripst hat.
Immer wenn ich Eingabemasken-Editieren aufrufe und dort ein verknüpftes Skript editieren will. dann kriebe ich eine Fehlermeldung die mir /EDIT endet.

Leider wird nicht die ganze Meldung dargestellt.

Das Verknüpfen von *.VBS mit einem Standardprogramm wäre schön, wenn es hier auch genutzt würde.

Danke trotzdem.

Nur: Wer weis hier mehr ???

Hallo

vielleicht hilft Dir das weiter.

Client Setup starten

-> Ändern
Bei den Einrichtungsoptionen 3/3
den Haken bei
-> Script-Dateien mit Script-Editor verknüpfen
raus

oder schau dir mal den Registry Eintrag in Windows genauer an

[HKEY_CURRENT_USER\Software\combit\combit Relationship Manager\Scripting]

Vielen Dank für Deine Antworten ;-}

Ich habe den Regestry-Key überprüft.
Schaut gut aus!
Ein Test mit Copy des Eintrages und Paste in die Adresszeile des Explorers öffnet das Programm.

ICH BIN RATLOS!!!

Hallo

Ich verstehe nicht was Du meinst ^^

Egal, in der Registry ist unter dem oben genannten Eintrag eine Zeichenfolge + Wert hinterlegt

Name = Editor
Wert = xxx\xxx\xxx\scite.exe

ändere mal den Wert in z.b.

C:\Notepad++\notepad++.exe

oder wo auch immer du deinen gewünschten Editor installiert hast

Wenn Du deinen Eintrag gemacht hast einfach den Explorer neu starten damit die Registry Werte neu geladen werden

Also einfach den Taskmanager (Strg + Alt + Entf) aufrufen und unter Prozesse die explorer.exe beenden. Der Explorer wird dann neu gestartet und somit die Registry neu geladen.

Sollte der Explorer nicht neu starten, einfach beim Taskmanager auf Datei gehen und Neuer Task (Ausführen…) wählen und dort explorer.exe eingeben. Dann Enter.

Mfg

© combit GmbH