+49 (0)7531 906010| service@combit.net

Kann CRM9 mit PostgreSQL 11 betrieben werden?

CRM Version 9.008

Ich möchte gerne mit dem CRM9 auf eine PostgreSQL Datenbank Version 11.4 zugreifen. Dies ist offiziell nicht unterstützt.

Ich erhalte die Meldungen:

  1. Die Version des von Ihnen verwendeten Datenkanksystem wurde für die Benutzung mit dieser Anwendung nicht freigegeben!

OK, kann ich mit leben.

  1. Der von Ihnen verwendete Datenbank-Client (libpq.dll) hat die Version 10.3, der Datenbank-Server jedoch die Version 11.4. Wir empfehlen dringend den Datenbank-Client (libpq.dll) auf eine neuere Version zu aktualisieren…

Das hört sich für mich so an, als wäre ein Update möglich. Ich würde auch den Fehler akzeptieren, der läßt sich aber nicht wie Fehler 1) ausblenden und würde mir die User irritieren.

Leider habe ich keine passende libpq.dll gefunden, die funktioniert. Die mit dem CRM gelieferte 10.0.2 1885 ist 492 KB groß.
Gefunden habe ich eine 11.0.3. 19142 mit 237 KB. Ein Austausch liefert mir jedoch einen Fehler und verhindert den Start des CRM:


libpq.dll: Das Betriebssystem kann %1 nicht ausführen.
Das angegebene Modul wurde nicht gefunden.

DBMS API Library loading Fails
This library is a part of DMBS Client Installation, not SQLAPI++


Scheint mir, als hätte ich die falsche dll.

  • Wo bekomme ich die richtige dll her?
  • Hat schon mal jemand mit CRM9 auf Postgres11 zugegriffen? Wenn ja, wie?

Hallo!
Ich habe es als neues Feature im cRM10 entdeckt. (PDF auf der Webseite)
Vermute also, dass es nicht mehr im cRM9 gehen wird.

Gruß
Pit

© combit GmbH