+49 (0)7531 906010| service@combit.net

Kalenderaufruf

am 18.003

Tach zusammen,

gibt es eine Möglichkeit, dem Programm zu sagen, daß beim Aufruf des Kalenders (Termine/Aufgaben) „alle Benutzer“ berücksichtigt werden?

Von Haus aus ist die Vorgabe immer der angemeldete Benutzer allein …

  • rwi -

Hi Robert,

das kann ich so nicht bestätigen: bei mir merkt sich die Anwendung meinen in der Combobox „Benutzer“ zuletzt gewählten Eintrag für das nächste Mal.

Der eingestellt Wert steckt in der Registry übrigens unter
HKEY_CURRENT_USER\SOFTWARE\combit\combit Relationship Manager\time manager\Settings
im Eintrag „UsersFilter“. Hat dieser Eintrag einen leeren Inhalt, dann sind es „Alle Benutzer“.

Gruß
Alex

Moin,

erstmal Dank fürs Schubsen auf die Registry … ich vergesse immer, dort zu schauen.

Mit „UsersFilter“ meinst Du wahrscheinlich „FilterUser“ … da geht es aber um was anderes.
Wenn Du im Programm auf den Filter-Button neben „Benutzer“ klickst, hast Du ja eine Liste mit allen Benutzern, die Du jetzt einzeln oder gemeinschaftlich anhaken könntest. Der obige Eintrag in der Registry klärt nach dem Motto „1; 3; 4; …“ lediglich, welche Benutzer für den evtl. gewünschten Filter in der Liste "vor"angehakt sind. Wird der Wert geleert, ist halt im Programm in der Filterliste als Grundeinstellung nichts angehakt.

Ändert leider nichts an meinem Grundproblem, weil ich ja gerne umgehen möchte, daß ich nach jedem Programmstart erst wieder neu den Filter setzen muß.

Ich werde noch ein wenig in der Registry wühlen … parallel gibt es ja auch noch den Zweig
\combit\timemanager\settings
Bringt mich aber bisher auch nicht weiter.

Trotzdem erstmal Dank.

Hi Robert,

Deine urspr. Frage war:

Stell in der Auswahlliste im Menüband von „Robert“ um auf „“ und beende die Anwendung und starte sie wieder. Jetzt sollte in der Auswahlliste bereits „“ (wieder) eingestellt sein. Das ist zumindest bei mir so. Bei dir auch? - > Problem gelöst!! :wink:

NEIN, ich meine genau den Eintrag, den ich genannt habe. :wink: Siehe beigefügtes Bild. Du musst den markierten Eintrag auf „“ setzen (bei geschlossener Anwendung, sonst überschreibt die den Eintrag beim Beenden ja wieder!) und schon ist beim nächsten Start „“ eingestellt.

Gruß

Alex

So hätte ich mir das vorgestellt … aber genau das passiert eben nicht.

NEIN, ich meine genau den Eintrag, den ich genannt habe. :wink: Siehe beigefügtes Bild.
[/quote]

Bild ist immer gut ;o)
Genau dieser Eintrag existiert bei mir nicht. Bzw: Hat nicht existiert … nur die anderen fünf Einträge.
Aber ich hab ihn jetzt hinzugefügt.

Wäre schön … macht er aber nicht.
Nebenbei: Der Eintrag wird beim Beenden auch nicht überschrieben, wie Du meinst. Er bleibt leer, aber ohne Funktion auf die Programmdarstellung. Und ohne Änderung in der Registry.

Seltsam das … und schade drum.

  • rwi -

Hi Robert,

für mich sieht das jetzt so aus, als wäre das ein Rechte-Problem in deiner Registry.

Geh nochmal in Regedit und dort auf den Zweig

HKEY_CURRENT_USER\SOFTWARE\combit\

und klicke mit Rechts drauf und wähle „Berechtigungen“ > „Erweitert“ und vergib deinem „normalen Benutzer“ (mit dem du die Anwendung benutzt) explizit „Vollzugriff“ und hake unbedingt auch "Alle Berechtigungseinträge für untergeordnete Objekte … ersetzen " an.

Wenn es dann auch nicht geht, fällt mir nur noch der combit Support ein.

Gruß Alex.

Tach auch,

Dank für Deinen nochmaligen Versuch, aber da ist alles so, wie es sein sollte. Auch die Vererbung war bereits korrekt. Hätte sich wahrscheinlich sonst auch an anderen Stellen bemerkbar gemacht, aber einen Versuch war es natürlich wert.

Nun ist das alles natürlich kein wirklich schlimmes Problem, eher etwas, was einen wuschig macht, weil man sieht, daß es eigtl. anders funktionieren sollte. Und zumindest bei Dir ja auch offensichtlich funktioniert.

Aus reiner Neugier:
Hier geht es um am-18.003 auf win_8.1 als Einzelinstallation … also lokal.
Ist es auf Deiner Seite ein anderer Rahmen?

Moin,

uuuuups… Also ich würde grundsätzlich immer mal das aktuelle Service Pack einspielen - vor allem wenn was nicht so funktioniert, wie es eigentlich soll, bzw. ein Feature „fehlt“, das andere (ich) zu haben scheinen. :wink:

Gruß

Alex

Moinsen,

alsooo …

  1. Dieses Problem ist jetzt gelöst.

  2. Ich stelle mir natürlich schon die Frage, warum ->Datei ->Optionen ->Einstellung … „auf neue Versionprüfen“ mir nichts von neuen Servicepacks erzählt hat. Die .004 hatte ich so gänzlich verschlafen, aber dafür bin ich jjetzt mit der .005 aktuell. Sei es drum.

  3. Das Problem mit dem Benutzerfilter scheint bis inkl. .004 bestanden zu haben. Zumindest heißt es in der aktuellen ReadMe/WhatsNew:

  1. Merci fürs Mitdenken.
  • rwi -

(Selbst)Korrektur: Bereits bei 18.004 wurde der Fehler behoben.

Ah ok, das erklärt’s :slight_smile: - hatte ich gar nicht nachgeguckt.

Von einem „Fehler“ zu sprechen - naja, ich glaub eher ,dass die von combit das dort halt überhaupt erst (evtl. auf Kundenwunsch hin? :wink: ) eingebaut haben, dass sich das gemerkt wird. Egal, Hauptsache es funzt!

Wünsche allerseits schonmal schöne Ostern!

Gruß

Alex

© combit GmbH