+49 (0)7531 906010| service@combit.net

crm.DialogForm gibt nothing zurück

Hallo,
leider helfen uns die bisherigen Antworten früherer Anfragen zu diesem Thema nicht weiter.

Problem ist dass das crm.DialogForm-Objekt mit „nothing“ zurückgegeben wird.

Wir haben eine Serverinstallation. Auf den Clients wurde das ClientSetup ausgeführt.

Der Fehler passiert aber nicht auf allen Clients.
Auf dem Client mit Fehler haben wir schon mehrfach den Client deinstalliert (ClientSetup.exe -uninstall) und wieder installiert (einschließlich Neustart). Jedoch erfolglos.

Vielleicht hat jemand eine Idee die uns weiterhilft. Schön wär’s. Vielen Dank schon mal für die Antworten.

Grüße
Annette Scherer

Registrierung der Datei cudi11.dll / cudi12.dll auf Clientcomputern

Notieren des Pfads zur Datei cudi11.dll / cudi12.dll, die im Ordner cRM der Basisinstallation auf dem Server liegt. Beispielsweise: \IHRSERVERPFAD\combit\cRM\cudi11.dll

Ausführen der Windows Eingabeaufforderung CMD als Administrator.

Bei 32 Bit Betriebssystemen: Ausführen des Befehls regsvr32 gefolgt von dem Pfad zur Datei.
Der Aufruf könnte folgendermaßen lauten regsvr32
\IHRSERVERPFAD\combit\cRM\cudi11.dll

Bei 64 Bit Betriebssystemen: Ausführen des Befehls regsvr32 aus dem
%SystemRoot%\Syswow64-Ordners gefolgt von dem Pfad zur Datei. Der Aufruf könnte
folgendermaßen lauten c:\windows\syswow64\regsvr32
\IHRSERVERPFAD\combit\cRM\cudi11.dll

Sollten Sie Leerzeichen in den combit-Pfaden verwendet haben, so ist der Aufruf hinter regsvr… in Hochkomma ("") zu stellen

Nach erfolgreicher Registrierung der Datei wird Erfolgsmeldung Meldung angezeigt.

Beste Grüße
Frank Wietzel

22-02-_2016_17-55-08.png

Hallo Herr Wietzel,

vielen Dank für Ihren Beitrag. Er war insofern hilfreich als dass wir festgestellt haben dass wir weder die cudi11.dll noch die cudi12.dll im cRM-Verzeichnis hatten sondern nur die cudi13.dll (vermutlich neu bei cRM8)
Wir haben vor dem Update das komplette Verzeichnis gelöscht um „alten Schrott“ los zu werden.

Wir haben von der Sicherung die beiden .DLLs wieder hergestellt. Der Fehler trat dann auch ohne Registrierung nicht mehr auf.

Insgesamt etwas merkwürdig da auf mind. einem Client der Fehler nicht auftrat (auch ohne cudi11/cudi12.dll) und auf allen das ClientSetup gelaufen ist.

Nochmals Danke und Grüße
Annette Scherer

Hallo zusammen,

ich grätsche ja nur ungern von hinten, aber …

…richtig ist die Registrierung genau der cudi13.dll (dreizehn!) über den von Frank beschriebenen Weg (oder über das V8-Client-Setup im Administrator-Schritt). Das Modul cudi??.dll muss immer zur verwendeten cmdL??.dll Version passen, die mit dem jeweiligen cRM Version ausgeliefert wird, d.h. bei Version 8: cudi13.dll (passend zur in V8 verwendeten cmdL13.dll).

Gruß

Alex.

Hallo zusammen,
vielen Dank Alex für die ergänzende Hintergrundinformation - doch zwischenzeitlich hatten wir das Problem gelöst.
Ich kam nur nicht dazu den Beitrag zu ergänzen.

Nachdem sich herausgestellt hat dass meine erste positive Rückmeldung auch nicht DIE Lösung war, war uns bald klar dass wir für den cRM8 die cudi13.dll benötigen.

Ein Registrieren der cudi13.dll hat nichts gebracht.
Wir haben dann vermutet dass eigentlich das Client-Setup diese Registrierung mit übernehmen müsste.

Nach dem Deinstallieren des Clients haben wir in der Registry den nach wie vor vorhandenen Key
HKEY_Current_User\Software\combit - gelöscht.

Anschließend das ClientSetup ausgeführt - mit dem Ergebnis dass der Fehler nicht mehr auftrat.

Viele Grüße und Danke für alle Beiträge.
Annette Scherer

© combit GmbH