+49 (0)7531 906010| service@combit.net

cRM.DialogForm gibt "Nothing" zurück

Hallo zusammen,

wie im „phone manager“-Thread kurz angerissen, habe ich folgendes Problem:

Jeder Auruf der Methode cRM.DialogForm (z.B. aus PhoneActivity.vbs oder Calculator.vbs) liefert auf allen Arbeitsplätzen (außer dem Server!) „Nothing“ zurück.

(In PhoneActivity.vbs wird daraufhin folgende Fehlermeldung ausgegeben:
„Für das Ereignis ‚Eingehender Anruf wurde gesucht‘ ist momentan eine erweiterte Funktionalität aktiviert. Der dafür erforderliche Dialog kann jedoch nicht dargestellt werden. Stellen Sie sicher, dass Sie den combit Relationship Manager auf diesem Arbeitsplatz mit Administrator-Rechten installiert haben (Haupt-Setup oder Client-Setup).“

Die Installation meiner Clients erfolgte jedoch definitiv mit Admin-Rechten (und wie andernorts empfohlen als Netzwerk-Installation).
Meine cRM-Version ist 6.008 Professional.

Irgendeine Idee, woran das liegen könnte?

Viele Grüße,
Elmar

Hallo Elmar,

vor einiger Zeit hatte ich ein ähnliches Problem. Vom combit-Support erhielt ich damals den Hinweis, die Datei ‚cudi11.dll‘ neu zu registrieren. Das löste dann auch das Problem.

[quote]Geben Sie in „Start -> Programme -> Zubehör -> Rechtsklick auf Eingabeaufforderung -> Als Administrator ausführen“ den folgenden Befehle ein: regsvr32 „\combit\crm\cudi11.dll“
Nach erfolgreicher Registrierung sollte eine Meldung ausgelöst werden.
Sollte dies nicht helfen, empfehlen wir die „client.exe“ nochmals explizit über Rechtsklick „Als Administrator ausführen“ vom Client zu starten.[/quote]

Gruß

Walter Rank

Hallo Walter,

vielen Dank für die prompte Hilfe! Nach der Neuregistrierung der dll mit regsvr32 funktioniert DialogForm jetzt.

Viele Grüße,
Elmar

Das gleiche Problem habe ich jetzt auch mit CRM 9.0007. Allerdings gibt es hier keine cudi11.dll

Hi Dietmar,

ersetze die beiden letzten Ziffern durch die Ziffern, zu der es eine cudi*.dll in deinem cRM-Installationsordner gibt. Müsste glaub cudi14.dll bei cRM9 sein bzw bei mir ist es cudi15.dll bei cRM10. (Bei mir hat die Registrierung allerdings das cRM10 Client Setup für mich erledigt.)

Gruß
Alex

Hallo Alex,

danke für die schnelle Antwort. Wo soll sich diese cudi*.dll denn verstecken? Im cRM Ordner jedenfalls nicht. Das einzige, was dem nahe kommt, ist eine cudm03.dll

Gruß
Dietmar

Moin,

sorry: cMdi14.dll bzw cMdi15.dll

Gruß
Alex

Danke, hat wunderbar funktioniert.

Gruß
Dietmar

© combit GmbH